LoadMyTracks 1.4 beta begins

ClueTrust has released the first changes in LoadMyTracks in almost 18 months. This new beta, the beginning of the 1.4 release cycle, contains a number of fixes for bugs in the previous 1.3 releases and contains updated libraries. Because of these changes, 1.4 will not be supported under 10.4. At this point, we expect to continue supporting LoadMyTracks under 10.5 for a while longer, as none of the new features we're looking at currently take advantage of specific 10.6-isms. Software Update in LoadMyTracks is the easiest way to keep up to date. And, we will be posting notifications on twitter if you follow loadmytracks.